• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I should also mention that I was able to install Forge on 1.12 
    • It seems like in other people's code they are able to put MyEntity.class as a parameter and it works fine? i can put the EntityType as a parameter and this works fine but then when i try and spawn the mob in-game I get an error message in the chat log   here is my new code: public class RegistryHandler { public static final DeferredRegister<EntityType<?>> ENTITY_TYPES = new DeferredRegister<>(ForgeRegistries.ENTITIES, Obamium.MOD_ID); public static void init(){ ENTITY_TYPES.register(FMLJavaModLoadingContext.get().getModEventBus()); } //Entities public static final RegistryObject<EntityType<MyEntity>> MYENTITY = ENTITY_TYPES.register("my_entity", () -> EntityType.Builder.create(ObamaEntity::new, EntityClassification.AMBIENT).size(1F, 2F).build("my_entity")); }   I am now calling registerEntityRenderingHandler in the doClientStuff method of my main class because someone said that's where I should put it since the rendering is done clientside. I have tried calling it elsewhere but the result is the same
    • I loaded up Minecraft, launched Forge 1.8.9, and got an error message saying, "Error: java.lang.RuntimeException: No OpenGL context found in the current thread." I opened the crash report and then removed the coremods listed, then got this:   ---- Minecraft Crash Report ---- WARNING: coremods are present: Contact their authors BEFORE contacting forge // Who set us up the TNT? Time: 4/1/20 12:40 PM Description: Unexpected error java.lang.RuntimeException: No OpenGL context found in the current thread.     at org.lwjgl.opengl.GLContext.getCapabilities(GLContext.java:124)     at org.lwjgl.opengl.GL11.glGetError(GL11.java:1299)     at net.minecraft.client.Minecraft.func_71361_d(Minecraft.java:944)     at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1029)     at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:349)     at net.minecraft.client.main.Main.main(SourceFile:124)     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)     at java.lang.reflect.Method.invoke(Method.java:497)     at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)     at net.minecraft.launchwrapper.Launch.main(Launch.java:28) A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- System Details -- Details:     Minecraft Version: 1.8.9     Operating System: Windows 10 (amd64) version 10.0     CPU: 12x Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz     Java Version: 1.8.0_51, Oracle Corporation     Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation     Memory: 807575792 bytes (770 MB) / 1073741824 bytes (1024 MB) up to 6442450944 bytes (6144 MB)     JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx6G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M     IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0     FML: MCP 9.19 Powered by Forge 11.15.1.1722 Optifine OptiFine_1.8.9_HD_U_I7 17 mods loaded, 17 mods active     States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored     U    mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)      U    FML{8.0.99.99} [Forge Mod Loader] (forge-1.8.9-11.15.1.1722.jar)      U    Forge{11.15.1.1722} [Minecraft Forge] (forge-1.8.9-11.15.1.1722.jar)      U    blockoverlay{1.2} [BlockOverlay] ([1.8.9] BlockOverlay - 2.0.jar)      U    customcrosshairmod{0.5.1-Forge} [Custom Crosshair Mod] ([1.8.9] Crosshairmod-v0.5.1.jar)      U    ToggleSneak{3.1.4} [ToggleSneak] ([1.8.9] Powns ToggleSneak Edit V1.1.jar)      U    sidebarmod{2.0} [Sidebar Mod Revamp] ([1.8.9] Sidebar Mod Revamp.jar)      U    autogg{2.0.4} [Auto GG] (AutoGG-2.0.4 (1.8.9).jar)      U    autotip{2.0.3} [Autotip] (Autotip-2.0.3 [1.8-1.11.2].jar)      U    musicplayer{2.0.2.24} [Music Player] (music_player-1.8.9-2.0.2.24.jar)      U    animations{6.7} [Orange's 1.7 Animations] (Orange's+1.7+Animations-6.7.jar)      U    quickplaypremium{1.0.2} [Quickplay Premium] (Quickplay Premium 1.8.9-1.0.2.jar)      U    quickplay{2.0.3} [Quickplay] (Quickplay-1.8.9-2.0.3.jar)      U    ResourcePackOrganizer{1.0.3} [Resource Pack Organizer] (ResourcePackOrganizer  MC-1.8.9  v1.0.3.jar)      U    timechanger{1.0} [TimeChanger] (TimeChanger-1.0 (1.8.9).jar)      U    publictogglechat{2.1.0} [Hypixel - ToggleChat] (ToggleChat-2.1.0-SNAPSHOT.jar)      U    enhancements{7.7} [Vanilla Enhancements] (Vanilla Enhancements-7.7.jar)      Loaded coremods (and transformers):      GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.     Launched Version: 1.8.9-forge1.8.9-11.15.1.1722     LWJGL: 2.9.4     OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.     GL Caps: Using GL 1.3 multitexturing. Using GL 1.3 texture combiners. Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported. Shaders are available because OpenGL 2.1 is supported. VBOs are available because OpenGL 1.5 is supported.     Using VBOs: No     Is Modded: Definitely; Client brand changed to 'fml,forge'     Type: Client (map_client.txt)     Resource Packs:      Current Language: English (US)     Profiler Position: N/A (disabled)     CPU: 12x Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz     The 5zig Mod Version: 3.12.4     The 5zig Mod Plugins: []     Forge: true     GUI: ~~NULL~~
    • Okay thank you. Then do i pass this into the registerEntityRenderingHandler method instead of  MyEntity.class?
    • No, it just tells the leaves how far above ground level to generate.   I did figure this out. Overriding the leaves, and logs, tag in resources/data/minecraft/tags/blocks solves this issue. Do the same for your logs.
  • Topics

  • Who's Online (See full list)