• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I'm using the latest version of forge 1.12.2 using a modpack of my own creation. Every time I generate the world with all mods installed, it is an endless void in all directions. Only modded structures still spawn in.  If I use half or a quarter of the mods, it works. There is some conflict here and I can't seem to find it no matter how hard I try.  I have never encountered a similar issue before, and I have failed to find anyone on the internet who has either.  I went to reddit and discord first, but neither had any idea what they were talking about, or how to fix it, so here I am. Any ideas? Log: https://drive.google.com/file/d/1AklMb4sEhuoBZDfy2hUoIflErLK6oFfo/view?usp=sharing
    • Thank you! I have poked around the vanilla code a bit but wasn't exactly sure what I was looking for in this case. I'll take a look at that class and then go from there.
    • I'm attempting to write and read members of my player capability class, and for things like my stamina, accuracy, fuel variables, when I exit the game and return, it 100% works and saves just fine. However, I also have a 3x3 grid of user bound indices that I've represented as a one dimensional array of integers, which I then created 9 integer data parameters of, registering and setting it like the others.   When I go to print these values within my serializenbt method, the correct values are printed, i.e. 2,4,1,0,...   However, when I print them after the readNBT call within the deserialize method after exiting the game and reloading, it just prints the default values for them, 0,0,0,0,... Note that this is immediately after calling readnbt in the same deserializeNBT method.   Both these methods are called on the logical server, and the client/server side for these variables are synced, so I don't believe it could be a server/client side issue. There's nothing weird with how I'm calling the two methods, since it works for all my other variables. The only time I set these variables to 0 is in the default/nondefault constructor as well.   Anyone know what it could be?
    • Still won't work David, Mojang's generators cache their blocks. What are you changing about stone and grass?
    • Did you remove it from your mods folder when you added the fg.deobf to your build.gradle?
  • Who's Online (See full list)