• Recently Browsing

    No registered users viewing this page.

  • Posts

    • DO NOT COPY CODE FROM THE GAME, especially entire files.   Are you trying to create an Entity that looks like a player, or are you trying to create a custom model for the player? In the first case you should probably create a custom entity and renderer for that entity. In case it is a Monster, MonsterEntity is probably a good starting point.   In case you are trying to render a custom player model, you should have a look at net.minecraftforge.client.event.RenderPlayerEvent. It get's fired whenever a player is being rendered and you can even disable player rendering alltogether and replace it with your own renderer.
    • I am creating a conveyor belt block for my mod. There are supposed to be several different blocks that can connect to Conveyor belts, including different types of conveyor belt blocks.   Should I use Tag<Block> to check wether an adjacent block should be connected to a conveyor block? Or are they supposed to only be used for cosmetic purposes?   Should I use an interface and instanceOf checking instead? Or should I use a custom lookup system, i.e. a static Set of blocks that are supposed to connect to a conveyor? I am not asking about testing for the presences of an inventory, conveyor blocks are not supposed to connect to inventories.
    • Yep, you're going to have to hack Minecraft's itemstack UI renderer. Have fun!
    • I began to notice problems today regarding my mods in forge. Whenever I try to load the game, during the end of phase 2, I get errors regarding BuildCraft. I deleted the mod and all files relating to it, and I then got errors in stage 3 with multiple lib mods, as well as Botania. I have tried reinstalling forge, re-installing the mods, and checking for updates, and nothing I have done has worked. I am using the latest version of 1.12.2 forge, being as follows:  14.23.5.2847   All other information should be listed with the logs.    I am guessing that my problem is not entirely a fault with the mods, asthe first line of the log shows as follows: ava.lang.RuntimeException: Invalid id 4096 - maximum id range exceeded. at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:295) referring to net.minecraftforge as the first line, I am implying something is going on with forge. I don't know for sure, though. I am not the best with logs, but from what I can tell, this is not exclusively related to the mods. Everything worked fine yesterday, and today, many of my mods are not working. I haven't been able to run minecraft with mods, unless I remove every single mod from my files, stripping the mods file to the bare minimum.   I know my computer can handle running as many mods as I have, and I am pretty sure that none of my mods are conflicting with other mods.      The pastebin page for the error is here: https://paste.dimdev.org/yoqodututo.mccrash I am looking for a way to fix the situation without removing multiple mods, and if I must, then that is the what I will do. Any help is appreciated.   Here is the error screen I get regarding BuildCraft, leading me to assume there is some fault with them. I don't think this is exclusive, as I get the error with many other mods if I delete BuildCraft, which is why I am posting this thread here instead of a referral to a specific mod.     Thank you!        
    • Has anyone ever dealt with an issue where foods and tools and the bottom tabs are all blank?  This keeps happening to me and Ive installed and uninstalled...  Trying to use 1.7.10.   The mod I was playing with is also missing lots of items.  But it happens without the mod being installed so I am assuming its a problem with forge or with how my computer is dealing with the forge install?  Regular vanilla no forge works fine.  Thanks for any help.   -earl-
  • Topics

  • Who's Online (See full list)