• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I began to notice problems today regarding my mods in forge. Whenever I try to load the game, during the end of phase 2, I get errors regarding BuildCraft. I deleted the mod and all files relating to it, and I then got errors in stage 3 with multiple lib mods, as well as Botania. I have tried reinstalling forge, re-installing the mods, and checking for updates, and nothing I have done has worked. I am using the latest version of 1.12.2 forge, being as follows:   All other information should be listed with the logs.    I am guessing that my problem is not entirely a fault with the mods, asthe first line of the log shows as follows: ava.lang.RuntimeException: Invalid id 4096 - maximum id range exceeded. at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:295) referring to net.minecraftforge as the first line, I am implying something is going on with forge. I don't know for sure, though. I am not the best with logs, but from what I can tell, this is not exclusively related to the mods. Everything worked fine yesterday, and today, many of my mods are not working. I haven't been able to run minecraft with mods, unless I remove every single mod from my files, stripping the mods file to the bare minimum.   I know my computer can handle running as many mods as I have, and I am pretty sure that none of my mods are conflicting with other mods.      The pastebin page for the error is here: https://paste.dimdev.org/yoqodututo.mccrash I am looking for a way to fix the situation without removing multiple mods, and if I must, then that is the what I will do. Any help is appreciated.   Here is the error screen I get regarding BuildCraft, leading me to assume there is some fault with them. I don't think this is exclusive, as I get the error with many other mods if I delete BuildCraft, which is why I am posting this thread here instead of a referral to a specific mod.     Thank you!        
    • Has anyone ever dealt with an issue where foods and tools and the bottom tabs are all blank?  This keeps happening to me and Ive installed and uninstalled...  Trying to use 1.7.10.   The mod I was playing with is also missing lots of items.  But it happens without the mod being installed so I am assuming its a problem with forge or with how my computer is dealing with the forge install?  Regular vanilla no forge works fine.  Thanks for any help.   -earl-
    • Now i updated my project to the latest snapshot and forge version. But the PlayerRenderer-class in the referenced librarys looks the same as before. also the two methods (wich call the RenderPlayerEvent-class) from the startpost are still the same. It still seams like the RenderPlayerEvent-class is only compatible with the vanilla PlayerRenderer-class.   should i create my own RenderPlayerEvent-classes for my custom PlayerRenderer-classes?   Cadiboo posted this link in one of the answers here: https://github.com/MinecraftForge/MinecraftForge/pull/6444 But i found nothing about this in the referenced librarys, i use now. And i found no mapped snapshot for 1.15.2 so i used the latest one for 1.15.1, that exist.
    • Thank you @Zeide, that was it. My model file was like this before { "parent": "item/generated", "textures": { "layer0": "firstmod:item/invincible_sword" } } after I changed the "parent":"item/handheld", my custom sword looks good now. Below is the screenshot Really appreciate your help
  • Topics

  • Who's Online (See full list)