• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am learning to make Minecraft mods. I added a new item into the game. Here is my code for @EventBusSubscriber : package com.gameatro.FirstMod; import com.gameatro.FirstMod.init.ModItemGroups; import com.gameatro.FirstMod.util.Reference; import net.minecraftforge.fml.common.Mod.EventBusSubscriber; import net.minecraftforge.registries.IForgeRegistryEntry; import net.minecraft.item.Item; import net.minecraft.util.ResourceLocation; import net.minecraftforge.event.RegistryEvent; import net.minecraftforge.eventbus.api.SubscribeEvent; @EventBusSubscriber(modid = Reference.MODID, bus = EventBusSubscriber.Bus.MOD) public class ModEventSubscriber { @SubscribeEvent public static void onRegisterItems(RegistryEvent.Register<Item> event) { event.getRegistry().registerAll( setup(new Item(new Item.Properties().group(ModItemGroups.MOD_ITEM_GROUP)), "example_item") ); } public static <T extends IForgeRegistryEntry<T>> T setup(final T entry, final String name) { return setup(entry, new ResourceLocation(Reference.MODID, name)); } public static <T extends IForgeRegistryEntry<T>> T setup(final T entry, final ResourceLocation registryName) { entry.setRegistryName(registryName); return entry; } } My modid is "fm" and I have placed my texture image "example_item.png" at the location "src\main\resources\assets\fm\models\item". I also have a "example_item.json" at the same location and the code inside it is: { "item.fm.example_item": "Example Item", "itemGroup.fm": "Example Mod" } But the image does not show in the game on building the mod. It just shows blank and pink texture. How do I fix this? What am I doing wrong?
    • You have Optifine for 1.14.4 installed...   No need for the quotes. That is what they are. Tell your friend to buy the game.
    • Same here, I thought I was all the mods I had added so I removed them all and tested on forge with no mods and the cows and such would spin sometimes while pathfinding.
    • I didn't use optifine 1.14.4, what I already mentioned in the main post. I don't have any other mods installed except 2 Xaero's ones.      It's my own server, dedicated version, which I paid for. I also said that I tested this bug on more than one server, therefore it's not the cause.   Server is set to allow "pirated clients" to join (I bought a game in 2013, and I said it in main post) to let my friend join in. The server wasn't "pirated" (it's not even a thing) because I paid for it myself.   To sum up, problem still not solved. I don't use Forge for the time being. I can't find the solution myself.
    • Do not make custom installers. All the user has to do is to drag the mods into the mods folder. There is no need for an installer for such a simple task. Custom installers are potentially reshipping mods in addition to security problems.
  • Topics

  • Who's Online (See full list)