• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Here's my RegistryEvents.java. https://pastebin.com/j9RyDL8U   You're right, I shouldn't have blindly followed a tutorial. I changed the entity rendering handler call to include a new RenderFactory that I had already created in my GrassmanEntityRender class that I hadn't been using. I think it's in my previous pastebin. I still am getting a white cube on /summon.  
    • I was trying to create an injured soldier but my blood blocks won't work. I've tried killing this and putting it where it died, putting my NPC down first, putting it down on natural and player-made blocks but none of the 3 textures are appearing on the blocks, no matter the angle I look at the block. Anything I'm doing wrong?
    • Bumping, if that's alright. One of my ideas for a solution would be to assign it a dedicated texture map that contains all of the variants, then somehow offset the UVs in a custom baked model. Not sure how to go about offsetting things like that, if that's even the best idea.
    • Hello, I'm trying to create a 1.12.2 Minecraft server which I've successfully done in the past with 1.12.2. I've gotten to the step of changing the EULA from false to true then launching the minecraft_server.1.12.2.jar file successfully. So I basically have a vanilla server without and mods since I cannot generate a mod folder. There are no popups when I double click the forge-1.12.2- file.    Here is my latest.log - https://pastebin.com/m9Smx7Rn   I've read other threads on similar errors. I've tried creating a Launch.bat file which results in the same outcome (nothing visually happens.) I've also tried launching previous servers with similar forge versions which results in the same outcome. One of the previous servers I tried launching which encountered the same error has forge-1.12.2- with Minecraft version 1.12.2.  I have not been able to launch any forge- .jar files even though I am able to launch all minecraft_server .jar files. (I recently installed jdk-12.0.2_windows-x64_bin.exe and Git-2.23.0-64-bit.exe for my Java class but I'm not sure if either of those would make a difference.)   I'm sorry if this is not enough information, if you need anything else I'll gladly provide.
    • After scouring the rendering code, I found that the problem was because the vertices weren't sorted in relation to the player's view, and that I could return true from TileEntity#shouldRenderInPass() during pass #1 instead of pass #0 to opt-in to the vertex sorting. The transparency now works perfectly.
  • Topics

  • Who's Online (See full list)