• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Apache log4j2 logger prints to console, not to file when run on server side. The same logger if placed in client side logs to file as expected. This worked fine on 1.7.10 but when transitioned from 1.7.10 to 1.8.9, the logger no longer logs to file but prints to console instead. the log4j2.xml is placed in the right folder(i.e src\main\resources) and works for other loggers.I don't understand why logger behaves one way in client side and other way in server side. Anyone facing similar issue for logger from 1.7.10 to 1.8.9? Does this have anything to do with the bus deprecation for event registration. Any help is appreciated GameLogger.java public class GameLogger {          public static GameLogger INSTANCE = new GameLogger();     public static final Logger logger = LogManager.getLogger("MyGame");     @SubscribeEvent     public synchronized void onPlayerTick(final TickEvent.PlayerTickEvent tick) {         if (tick.phase == Phase.END) {             if (tick.player.isEntityAlive()) {                             logger.info("Logger is working");                     }                 }             }         } log4j2.xml     <RollingRandomAccessFile name="StatsFile" fileName="logs/StatsFile-latest.log" filePattern="logs/StatsFile/%d{yyyy-MM-dd-HH}{GMT}-%i.log.gz">                 <PatternLayout pattern="%d{yyyy/MM/dd HH:mm:ss}{GMT}%msg%n" />                 <Policies>                     <TimeBasedTriggeringPolicy />                     <OnStartupTriggeringPolicy />                 </Policies>             </RollingRandomAccessFile>                  <Logger level="info" name="MyGame" additivity="false">                 <AppenderRef ref="StatsFile" />             </Logger>             <Root level="all">                 <AppenderRef ref="FmlSysOut" level="INFO" />                 <AppenderRef ref="ServerGuiConsole" level="INFO" />                 <AppenderRef ref="FmlFile"/>             </Root> The logger works fine if i place it in separate client class with client tick logging. It prints to log file as expected, but for some reason does not do the same when placed on server sided class.
    • Hi,   I've been trying to use Minecraft Forge for Minecraft 1.14.4 with Ubuntu 19.10. I installed it using the normal installer.   When I click "play" in the Minecraft Launcher with the "forge" profile, the Minecraft window opens for about a second, and I can see "Found 2 modfiles to load [newline] Launching minecraft" but then it crashes.   I don't have any mods installed, and I've tried using a plain .minecraft but it still crashes. Vanilla 1.14.4 works fine. I'm using the latest version of Forge.   debug.log: https://pastebin.com/raw/P67GJmRt latest.log: https://pastebin.com/raw/g2LS2sad   Thanks in advance.
    • I too am having this issue, Im going to try to include some logs also, maybe we can get down to the bottom of it cause I am at a loss.  
    • Ah okay, that makes a lot more sense now. Thanks.
    • Correct. But you get it from the game once, at which point it does not exist yet, and remember the value you got and never ask again. You must ask every time and not remember the value.
  • Topics

  • Who's Online (See full list)