• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Oooh, those first ideas seem pretty feasible.  There's code in the game that allows for "unnatural spawns" (i.e. interdimensional teleportation), so I might be able to utilize that to recall them.  Possibly implement a delay before respawning them, so they don't instantly warp... hmmm...   Though, I suppose that'd hinge on the hive itself being loaded.  Hmm.  Is there a way to load a certain chunk based off a block even when no players are near?  I know some mods have managed to make chunk loaders but I'm not sure of a good example offhand...   That's another good option!  I've definitely got some more direction now, so thank y'all for your help!
    • I have started having issues with my server starting to randomly crash and I looked each and every "resolution with the error description: "Exception in server tick loop" and tried it all, but nothing works. I hope my friends and I do not need to reset the world and/or our characters since we are finally nearing the end game. Here are the crash report and latest logs: Crash Report: https://pastebin.com/XHQMW9XU Latest Log: https://pastebin.com/iFxxDcGx I'm studying Java but I am still a novice so any help and education would be appreciated.
    • also there seems to be a problem with the spoiler feature in your forums. 
    • thank you so much for helping me find what was wrong
    • I've been having a problem with my Slimeblock Elevator on a Minecraft server: while I'm being launched up, my game crashes!  java.lang.IllegalArgumentException: The value 18336 is not in the specified inclusive range of 0 to 16383 Previously, this problem has arose and disappeared. It used to stop happening when I turned off OptiFine. I submitted an issue to them, and they said it wasn't OptiFine. The issue was fixed, anyways, but today, it started happening again. I had just updated my mods (which was NOT the problem, btw), and when I hit the button to go up, I crashed again! The first thing I did was remove OptiFine from my mods folder, to see if it was causing it again. It continued to crash. Next, I removed everything from my mods folder (with the exception of the .rar I put all the mods into) and tried it again. Still crashed.  java.lang.IllegalArgumentException: The value 18336 is not in the specified inclusive range of 0 to 16383 Why?   It's funny. I used to get different numbers each time. Today, they were always the same: 18336 is not in the specified inclusive range of 0 to 16383.    I then tried removing my resource packs (except mod resources that I couldn't remove). It finally didn't crash! I was still going to write a bug report because it worked fine no matter what on Vanilla. But, I read the rules and saw that in order to get support, you must be on the latest version. So I "upgraded" from 31.2.0 to 31.2.8. Now it crashed both with and without the resource packs! YAY! (Side note, if it helps: the 31.2.8 was on a different game directory than 31.2.0 but at this point they were both free of mods in the mods folder.)   So, I can verify that this is a Minecraft Forge issue, as it happens without any mods, with and without resource packs, and never crashes on Vanilla.   If it helps, the game seemed to crash more consistently with resource packs ON, though it may be coincidental as going back to 31.2.0 and disabling resource packs still caused it after I tested 31.2.8 even though they were launched on different game directories, so it wasn't a file in one or the other that triggered it. I'll also add that I got the same number values (18336 is not in the specified inclusive range of 0 to 16383) both in the default ~/.minecraft/ directory and the one I have my mods on.    Here are the relevant logs and crash reports: Stacktrace (completely identical between both game directories and 2 back-to-back crashes per directory):  -- Head -- Thread: Render thread Stacktrace: at org.apache.commons.lang3.Validate.inclusiveBetween(Validate.java:1032) at net.minecraft.util.BitArray.func_219789_a(SourceFile:37) at net.minecraft.util.palette.PalettedContainer.func_222643_a(PalettedContainer.java:121) at net.minecraft.util.palette.PalettedContainer.func_222641_a(PalettedContainer.java:110) at net.minecraft.world.chunk.ChunkSection.func_177484_a(SourceFile:60) at net.minecraft.world.chunk.ChunkSection.func_222629_a(SourceFile:54) at net.minecraft.world.chunk.Chunk.func_177436_a(Chunk.java:250) at net.minecraft.world.World.func_180501_a(World.java:177) at net.minecraft.tileentity.PistonTileEntity.func_73660_a(PistonTileEntity.java:293)   Most Recent 31.2.0 Crash report (modded directory with no mods in mods folder, but there's an archive with the mods in that)   Most Recent 31.2.8 Crash report (default directory with no mods in mods folder, but there's a few folders used by some Fabric mods. There are no Fabric mods in the folder, either.)   31.2.0 latest debug.log   31.2.8 latest debug.log   I hope you guys can fix this! Thanks in advance for your help!
  • Topics

  • Who's Online (See full list)