• Recently Browsing

    No registered users viewing this page.

  • Posts

    • This was originally posted in another thread but I think it makes much more sense as its own question. How do you register entity world spawns in 1.15.1? I looked through Cadiboo's tutorial but he hasn't gotten to that bit yet. The code I have is public static void registerEntityWorldSpawn(EntityType<?> entity, Biome... biomes) { for (Biome biome : biomes) { if (biome != null) { biome.getSpawns(entity.getClassification()).add(new SpawnListEntry(entity, 10, 2, 10)); } } } which is called as  registerEntityWorldSpawn(HOP_MOB, Biomes.FOREST, Biomes.BIRCH_FOREST, Biomes.DARK_FOREST, Biomes.BIRCH_FOREST_HILLS, Biomes.DARK_FOREST_HILLS, Biomes.FLOWER_FOREST, Biomes.TALL_BIRCH_FOREST); in a @SubscribeEvent public static void registerEntities(final RegistryEvent.Register<EntityType<?>> event) {} which is itself in a  @Mod.EventBusSubscriber(bus=Mod.EventBusSubscriber.Bus.MOD) public static class RegistryEvents{} Within my main mod class. Sorry for the odd format but it felt the cleanest way to share my code. I know enough java to know that it isn't some basic syntax error, and anyway, when I run it I don't get any errors. The issue is the mob doesn't spawn naturally at all. I can spawn it in fine with my custom spawn egg and it works perfectly, so the issue is only with natural world spawns. The method I'm using, as seen above, was taken from a 1.14 tutorial released in July 2019, so the reason it doesn't work definitely has to do with something specific to 1.15. That's all the useful info I have, unfortunately. And if I'm wrong in any of my assumptions please let me know. Thanks!
    • I tried to use the 1.10 version of forge and this happened 
    • Update your JDK to the latest version of Java 8. https://adoptopenjdk.net/
    • FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring root project 'Mod1'. > Could not resolve all artifacts for configuration ':classpath'.    > Could not resolve net.minecraftforge.gradle:ForgeGradle:3.+.      Required by:          project :       > Failed to list versions for net.minecraftforge.gradle:ForgeGradle.          > Unable to load Maven meta-data from https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml.             > Could not get resource 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.                > Could not GET 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.                   > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. * Get more help at https://help.gradle.org
    • When I right-click my mod block with torches in my off-hand, it tries to place the torch on the block--briefly emitting light--then consumes the torch (count decreases by one), and finally still opens up the GUI. Then, if I exit to the menu and then return, I have all my torches back.   When right-clicking my mod block with any placeable block, the animation of placing the block appears before opening the GUI. These blocks remain in the hotbar when this happens.   Instead of pasting huge codeblocks--unless that is preferable--here are links to my code: Block Block TileEntity Block Container Block Screen   Any and all help is appreciated!
  • Topics

  • Who's Online (See full list)