• Recently Browsing

    No registered users viewing this page.

  • Posts

    • alll right id like some help, i am running Minecraft Java on Windows 10 Pro. when i tried to download the Forge luancher for 1.15.1 and it loaded up on the bottom tab que. so when it looked liked it finshed i clicked it (once) and i t asked me how i'd like to open the file. i pushed on notes. Now when it opened it looked like a whole bunch of jibberish symbols to me ( i am assuming the symbols are some mis-translation of the code).      Sooo i deleted that note then re-tried, this time it went to notes automaticlly., not giving me the options choice as before.     1. Does anyone knows how to fix or is this not reversable   2. does anyone have any reccommenditions on who would know?     :{  
    • Hello Minecraft Forge Forums,   I kind of have a little bit of an issue with trying to run my mod.   I created a Gradle-based mod and I am using an external dependency. I wanted to embed the dependency into my mod's jar file. I used the Shadow plugin for Gradle, it compiles fine, but when I try to run the mod, I get java.lang.NoSuchFieldError when trying to use any static field in net.minecraft.init.Biomes.    Here is my build.gradle file: buildscript { repositories { jcenter() maven { url = "https://files.minecraftforge.net/maven" } } dependencies { classpath 'net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT' classpath 'com.github.jengelman.gradle.plugins:shadow:1.2.3' } } apply plugin: 'net.minecraftforge.gradle.forge' //Only edit below this line, the above code adds and enables the necessary things for Forge to be setup. apply plugin: 'com.github.johnrengelman.shadow' version = "0.1" group = "io.github.mymod" // http://maven.apache.org/guides/mini/guide-naming-conventions.html archivesBaseName = "mymod" shadowJar { classifier = null relocate "org.apache.commons.imaging", "killme.org.apache.commons.imaging" dependencies { include(dependency(files("lib/commons-imaging-1.0-alpha1.jar"))) //exclude(dependency(files("lib/CubicChunks-1.12.2-0.0.970.0-SNAPSHOT-all.jar"))) //exclude(dependency(files("lib/CubicWorldGen-1.12.2-"))) } } sourceCompatibility = targetCompatibility = '1.8' // Need this here so eclipse task generates correctly. compileJava { println "icij" sourceCompatibility = targetCompatibility = '1.8' } minecraft { println "icimc" version = "1.12.2-" runDir = "run" // the mappings can be changed at any time, and must be in the following format. // snapshot_YYYYMMDD snapshot are built nightly. // stable_# stables are built at the discretion of the MCP team. // Use non-default mappings at your own risk. they may not always work. // simply re-run your setup task after changing the mappings to update your workspace. mappings = "snapshot_20171003" // makeObfSourceJar = false // an Srg named sources jar is made by default. uncomment this to disable. } dependencies { println "icidp" // you may put jars on which you depend on in ./libs // or you may define them like so.. //compile "some.group:artifact:version:classifier" //compile "some.group:artifact:version" // real examples //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev' // adds buildcraft to the dev env //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env // the 'provided' configuration is for optional dependencies that exist at compile-time but might not at runtime. //provided 'com.mod-buildcraft:buildcraft:6.0.8:dev' // the deobf configurations: 'deobfCompile' and 'deobfProvided' are the same as the normal compile and provided, // except that these dependencies get remapped to your current MCP mappings //deobfCompile 'com.mod-buildcraft:buildcraft:6.0.8:dev' //deobfProvided 'com.mod-buildcraft:buildcraft:6.0.8:dev' provided files("lib/CubicChunks-1.12.2-0.0.970.0-SNAPSHOT-all.jar") provided files("lib/CubicWorldGen-1.12.2-") compile files("lib/commons-imaging-1.0-alpha1.jar") // for more info... // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html // http://www.gradle.org/docs/current/userguide/dependency_management.html } processResources { println "icipr" // this will ensure that this task is redone when the versions change. inputs.property "version", project.version inputs.property "mcversion", project.minecraft.version // replace stuff in mcmod.info, nothing else from(sourceSets.main.resources.srcDirs) { include 'mcmod.info' // replace version and mcversion expand 'version':project.version, 'mcversion':project.minecraft.version } // copy everything else except the mcmod.info from(sourceSets.main.resources.srcDirs) { exclude 'mcmod.info' } }   It seems to be caused by the "classifier = null" line, assigning classifier to anything causes the above error, however, if I remove that line, the dependency does not appear in my jar file.    (The dependency is Apache's Commons-imaging [org.apache.commons.imaging])   All help and answers are appreciated 😀  
    • I tried to implement the code from debug overlay :   RayTraceResult result; BlockPos blockpos = null; result = event.getPlayer().func_213324_a(20.0D, 0.0F, true); if (result.getType() == RayTraceResult.Type.BLOCK) { blockpos = ((BlockRayTraceResult)result).getPos(); } if ((event.getPlayer().getHeldItemMainhand().getItem() == Items.GLASS_BOTTLE || event.getPlayer().getHeldItemMainhand().getItem() == Items.WATER_BUCKET) && (!event.getWorld().getBiome(blockpos).toString().contains("River"))) { event.setCanceled(true); }   But its still going by the block that the player is standing on, not looking at. 
    • Sorry... There is still a strange problem...   I add this to my main class, and I think it work. FMLJavaModLoadingContext.get().getModEventBus().addListener(PacketHandler::register); But it still throws an error like this: [08:57:50] [Server thread/ERROR] [ne.mi.fm.ne.si.IndexedMessageCodec/SIMPLENET]: Received empty payload on channel fml:handshake   The game will not exit, but there is nothing when I left click my item.   Maybe I make some stupid mistakes...
    • if (this.leftClickCounter <= 0 && !this.player.isHandActive()) { if (leftClick && this.objectMouseOver != null && this.objectMouseOver.getType() == RayTraceResult.Type.BLOCK) { BlockRayTraceResult blockraytraceresult = (BlockRayTraceResult)this.objectMouseOver; BlockPos blockpos = blockraytraceresult.getPos(); if (!this.world.isAirBlock(blockpos)) { Direction direction = blockraytraceresult.getFace(); if (this.playerController.onPlayerDamageBlock(blockpos, direction)) { this.particles.addBlockHitEffects(blockpos, blockraytraceresult); this.player.swingArm(Hand.MAIN_HAND);   I don't understand this code, objectMouseOver is not set anywhere in the class, so how is it being used? 
  • Topics

  • Who's Online (See full list)