• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Take a look at your disenchanter block class: @Override public boolean onBlockActivated(BlockState state, World world, BlockPos pos, PlayerEntity player, Hand hand, BlockRayTraceResult result) { if (!world.isRemote) { TileEntity tileEntity = world.getTileEntity(pos); if (tileEntity instanceof INamedContainerProvider){ NetworkHooks.openGui((ServerPlayerEntity) player, (INamedContainerProvider) tileEntity, tileEntity.getPos()); } else { throw new IllegalStateException("Our named container provider is missing."); } return true; } return super.onBlockActivated(state, world, pos, player, hand, result); } If you follow the control flow, the client-side block will always return super.onBlockActivated(state, world, pos, player, hand, result); The effects you are describing seem to be caused by the client and server following different paths here, the server returning true after opening the gui, and the client returning super.onBlockActivated, which I'm pretty sure defaults to false.
    • This was originally posted in another thread but I think it makes much more sense as its own question. How do you register entity world spawns in 1.15.1? I looked through Cadiboo's tutorial but he hasn't gotten to that bit yet. The code I have is public static void registerEntityWorldSpawn(EntityType<?> entity, Biome... biomes) { for (Biome biome : biomes) { if (biome != null) { biome.getSpawns(entity.getClassification()).add(new SpawnListEntry(entity, 10, 2, 10)); } } } which is called as  registerEntityWorldSpawn(HOP_MOB, Biomes.FOREST, Biomes.BIRCH_FOREST, Biomes.DARK_FOREST, Biomes.BIRCH_FOREST_HILLS, Biomes.DARK_FOREST_HILLS, Biomes.FLOWER_FOREST, Biomes.TALL_BIRCH_FOREST); in a @SubscribeEvent public static void registerEntities(final RegistryEvent.Register<EntityType<?>> event) {} which is itself in a  @Mod.EventBusSubscriber(bus=Mod.EventBusSubscriber.Bus.MOD) public static class RegistryEvents{} Within my main mod class. Sorry for the odd format but it felt the cleanest way to share my code. I know enough java to know that it isn't some basic syntax error, and anyway, when I run it I don't get any errors. The issue is the mob doesn't spawn naturally at all. I can spawn it in fine with my custom spawn egg and it works perfectly, so the issue is only with natural world spawns. The method I'm using, as seen above, was taken from a 1.14 tutorial released in July 2019, so the reason it doesn't work definitely has to do with something specific to 1.15. That's all the useful info I have, unfortunately. And if I'm wrong in any of my assumptions please let me know. Thanks!
    • I tried to use the 1.10 version of forge and this happened 
    • Update your JDK to the latest version of Java 8. https://adoptopenjdk.net/
    • FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring root project 'Mod1'. > Could not resolve all artifacts for configuration ':classpath'.    > Could not resolve net.minecraftforge.gradle:ForgeGradle:3.+.      Required by:          project :       > Failed to list versions for net.minecraftforge.gradle:ForgeGradle.          > Unable to load Maven meta-data from https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml.             > Could not get resource 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.                > Could not GET 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.                   > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. * Get more help at https://help.gradle.org
  • Topics

  • Who's Online (See full list)