• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Good catch, thank you. It took a few hours to figure out, but a custom class extending ItemTippedArrow worked like a charm. Appreciate the help! (Solved)
    • I just looked into what you mentioned. Most calls use a field from ParticleTypes which I could do if the needed particle wasn't configurable or there was a way to get the ParticleTypes fields from the chosen particle in the configs. The other ones I saw was creating a new instance of ItemParticleData, BlockParticleData, or RedstoneParticleData, also I could use those if the particle I was handling needed one of them. But that is not the case. I am getting the particle from the ForgeRegistries which uses ParticleType. I have been digging around and am struggling to find a way to get from ParticleType to IParticleData and currently is is looking like I would have to re-register the particle which I know can't be the correct way to do it.
    • Minecraft forge for 1.9 keeps crashing as soon as i click "play" it either says: Failed to download file, the file contents differ from what was expected. Name: jopt-simple-4.6.jar URL: https://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar Filename on disk: jopt-simple-4.6.jar Path: C:\Users\Echo\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.6\jopt-simple-4.6.jar Exists: File or "minecraft launcher has stopped working".... any way to fix this?
    • Hello, 3 or 4 days ago, I restarted my computer. Since then I can't play Minecraft. Every time I start the game, the launcher crashes. I tried to delete Minecraft and then download it again, in vain. I did the same with Forge, but it's the same thing.   I searched for crash reports, but there was none. I use 1.14.4 - 28.1.0 version. N.B : Minecraft works when I play with the original version of Minecraft (1.14.4).   Hope you can help me. Benjamin.  
    • [12:46:21] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [12:46:21] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [12:46:21] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker [12:46:21] [main/INFO] [FML]: Forge Mod Loader version for Minecraft 1.12.2 loading [12:46:21] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_231, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_231 [12:46:22] [main/WARN] [FML]: The coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin) is not signed! [12:46:22] [main/WARN] [FML]: The coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin) is not signed! [12:46:22] [main/INFO] [FML]: Searching C:\Users\Cleiton\AppData\Roaming\.minecraft\mods for mods [12:46:22] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in AdPother-1.12.2- This is not recommended, @Mods should be in a separate jar from the coremod. [12:46:22] [main/WARN] [FML]: The coremod com.endertech.minecraft.mods.adpother.LoadingPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft [12:46:22] [main/WARN] [FML]: The coremod LoadingPlugin (com.endertech.minecraft.mods.adpother.LoadingPlugin) is not signed! [12:46:22] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in AppleCore-mc1.12.2-3.2.0.jar. This is not recommended, @Mods should be in a separate jar from the coremod. [12:46:22] [main/WARN] [FML]: The coremod AppleCore (squeek.applecore.AppleCore) is not signed! [12:46:22] [main/INFO] [FML]: Loading tweaker guichaguri.betterfps.tweaker.BetterFpsTweaker from BetterFps-1.4.8.jar [12:46:22] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in DynamicLights-1.12.2.jar. This is not recommended, @Mods should be in a separate jar from the coremod. [12:46:22] [main/WARN] [FML]: The coremod atomicstryker.dynamiclights.common.DLFMLCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft [12:46:22] [main/WARN] [FML]: The coremod DLFMLCorePlugin (atomicstryker.dynamiclights.common.DLFMLCorePlugin) is not signed! [12:46:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [12:46:22] [main/INFO] [LaunchWrapper]: Loading tweak class name guichaguri.betterfps.tweaker.BetterFpsTweaker [12:46:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker [12:46:22] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [12:46:22] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [12:46:22] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper [12:46:25] [main/INFO] [FML]: Found valid fingerprint for Minecraft. Certificate fingerprint cd99959656f753dc28d863b46769f7f8fbaefcfc [12:46:25] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing [12:46:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper [12:46:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper Exception in thread "main" [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NoClassDefFoundError: com/endertech/minecraft/mods/adpother/transformers/AcidRain$Vanilla [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at com.endertech.minecraft.mods.adpother.LoadingPlugin.getASMTransformerClass(LoadingPlugin.java:53) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper.injectIntoClassLoader(CoreModManager.java:129) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraft.launchwrapper.Launch.launch(Launch.java:115) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: Caused by: java.lang.ClassNotFoundException: com.endertech.minecraft.mods.adpother.transformers.AcidRain$Vanilla [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at java.lang.ClassLoader.loadClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     at java.lang.ClassLoader.loadClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]:     ... 4 more [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]: Caused by: java.lang.NoClassDefFoundError: com/endertech/minecraft/forge/coremod/ForgeClassTransformer [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at java.lang.ClassLoader.defineClass1(Native Method) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at java.lang.ClassLoader.defineClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at java.security.SecureClassLoader.defineClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     ... 6 more [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]: Caused by: java.lang.ClassNotFoundException: com.endertech.minecraft.forge.coremod.ForgeClassTransformer [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:101) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at java.lang.ClassLoader.loadClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     at java.lang.ClassLoader.loadClass(Unknown Source) [12:46:25] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:-1]:     ... 10 more Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release Java HotSpot(TM) 64-Bit Server VM warning: MaxNewSize (6291456k) is equal to or greater than the entire heap (6291456k).  A new max generation size of 6291392k will be used.  
  • Topics

  • Who's Online (See full list)