• Recently Browsing

    No registered users viewing this page.

  • Posts

    • @Ugdhar Thanks for your feedback!   I made this, because I find that the dark forum-native highlighting is not very well optimized.  I used this post to test some changes I have made to the css and I have now submitted a Pull Request to have the changes applied to the forum here:   https://github.com/MinecraftForge/Web/pull/5    The title is partially based on this famous reddit post, which was once the most upvoted post there, but I also wrote title that because this post is not really all that important and should be ignored https://www.reddit.com/r/pics/comments/92dd8/test_post_please_ignore/
    • RenderPlayerEvent gives you access to the following fields:     public PlayerRenderer getRenderer() public float getPartialRenderTick() public MatrixStack getMatrixStack() public IRenderTypeBuffer getBuffers() public int getLight() These should be more than enough to do your own rendering.   Using these is basically the same as any other custom entity renderer.
    • I know you said ignore, but if you'd like any feedback/opinions, Intellij Dark looks best/easiest to read IMO (I am using the dark forum theme).
    • This is likely because the annotation cannot find / generate an instance of your class.   Try to use an inner static class instead. Like this:     public class DataGenerators { @Mod.EventBusSubscriber(bus = Mod.EventBusSubscriber.Bus.MOD) public static class GatherDataSubscriber { @SubscribeEvent public static void gatherData(GatherDataEvent event) { DataGenerator generator = event.getGenerator(); if (event.includeServer()) { generator.addProvider(new Recipes(generator)); generator.addProvider(new LootTables(generator)); } } } } Or use DeferredRegister instead.
    • Using Eclipse, I had to run the eclipse tasks (from the commandline) twice to get it to let me to view sources, both when originally setting up the project and when updating forge/mappings in build.gradle. Otherwise when trying to look up classes and such it would tell me source was not available. No clue why, but like I said, running the tasks once, then opening in eclipse won't let me view sources, close it down, rerun tasks again, and I can view sources.   This was using eclipse 2019-12.
  • Topics

  • Who's Online (See full list)