• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Are you still having this problem? In eclipse go to Run>Run Configurations, select runClient and Arguments and in VM Arguments replace -Dforge.logging.console.level=debug with -Dforge.logging.console.level=info. This worked for me.
    • There is some information on rendering changes here, have you already seen it?   https://gist.github.com/williewillus/30d7e3f775fe93c503bddf054ef3f93e
    • Hi, I'm creating a mod containing several block types that probably aren't in the ConquestRegorged modification if the mod comes out on version 1.15. I decided to write this post because I can't deal with two probably simple things.   MC version: 1.15.2 Forge version: 31.1.0   Git repo: https://github.com/fronczek7f/ConquestReforged-Addon_1.15.2 First problem:   I created the RoofTileBlock class based on StairsBlock and the block itself uses the wavefront .obj format model. I wanted it to be a wavefront model because I can't make corners in Blockbench. As far as I know, in the current version 1.15 you do not need to use OBJLoader anymore, all you have to do is indicate in the model json file that you use the vol. Format And so I did, partly I helped myself using MinecraftByExample and the example given there. The effect is like the photo below but I have some problems...     It looks good to me but as you will see in the next picture there is a problem that I am currently unable to fix.     Normally in previous versions of Forge I would use the isOpaqueCube, isFullBlock, isFullCube etc. methods but at the moment I do not know what it can be and whether it is available as public. Most of the methods that I normally used in 1.12.2 just are gone or exist under a different name.   Second problem:   It concerns the rendering of the model itself, the problem can be seen in the photo.     When I put one block this problem is not visible but if I put next block, no matter what one triangle becomes a bit darker and I do not know what it depends on.
    • Seems like you're using the Forge MDK 31.1.0. I had the exact same issue with it, even if I made sure to correclty setup my paths and workspace (JAVA_HOME, JRE_HOME and Path). I didn't even have Java 9 anywhere on my PC. I just went for the latest Forge MDK update (31.1.41) and it worked just fine after reinitializing my workspace (deleting the .metadata folder in your workspace emplacement, or directly from Eclipse).   Hope that can help :)
    • So after taking around a year break from playing Minecraft I have decided to get back into the game and what better way to do that then a lets play. Join me as I adventure across the land and discover all the new content that has been added since I last played.   Most Recent Episode! https://www.youtube.com/watch?v=oPM0Pf0-Glw   Episode 1 https://www.youtube.com/watch?v=cZ2d-cTr8RE&t   Episode 2 https://www.youtube.com/watch?v=TuVsZPSYvac&t=   Episode 3 https://www.youtube.com/watch?v=y5XfQPPOi9w&t   Episode 4 https://www.youtube.com/watch?v=ObRFCRau4zo&t   Episode 5 https://www.youtube.com/watch?v=0m_x_AOYXe4&t   Episode 6 https://www.youtube.com/watch?v=Cg5qHzuri5Y&t   Episode 7 https://www.youtube.com/watch?v=IvnPHzy8P20&t   Episode 8 https://www.youtube.com/watch?v=oPM0Pf0-Glw
  • Topics

  • Who's Online (See full list)