• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Good day, I have been unable to play any 1.12.2 beyond the first time.  At first it had to do with CraftTweaker, as stated here, but after any solution I found not work I just got rid of CraftTweaker. Now, minecraft boots the first time after a fresh modpack install, but freezes at modidmapping any time after the first. I am currently trying to play the MC Eternal modpack, with only a couple qol extra mods, and it gets stuck with or without them so they are not the problem, and one suggestion said give more ram, so I did, but that did not help, it still gets stuck, with plenty of ram remaining. I have no idea what could be causing it to get stuck at modidmapping. Here is the latest log from when it got stuck and the log before that that did not get stuck, along with the debug logs from the same thing. Also, I use optifine but I have tried running it without optifine and it will still get stuck at modidmapping. Any help would be greatly appreciated, please and thank you. I have tried asking everywhere and have gotten nothing, this is the only other place I could think of. Latest log Latest debug Successful boot log Successful boot debug Edit: After digging through the logs I found that in the successful boot log that it says ModIDMapping took ~900 seconds, or ~15 minutes. This can’t be correct, as when I sat there and watched it boot it took only 8 minutes to fully load up. But in the unsuccessful boot log, it says ModIDMapping took 0 seconds and nothing else. I don’t know what this means.
    • I want to know one of these methods, but i didnt find any. Also, if u have a method, write an example so i can understand how to use it. I'm using mod coder pack in  eclipse
    • Block right click takes precedence over item right click. Since the flower pot has a right-click action onItemUse never executes. You need to use onItemUseFirst, which is called before block right click.   This does not make sense and will in fact be true for any block that doesn't have properties, because it's just comparing to an empty list...
    • Hello,   I posted this same question yesterday in regards to Minecraft 1.12 and was told that 1.12 is no longer supported and I will need to upgrade to a newer version. Given that 1.14 is in LTS and the next closest version I will begin upgrading to that. However, the question posed in the original thread remains the same even if on a new version of Minecraft and I may as well try to get ahead of the ball. I have quoted the original post below but fellow readers should be aware that all the links other than the OpenGL docs link link to resources for 1.12. I have left the links in as I'm not sure how useful they will or won't be to future readers of this thread.  
    • Hello,   I wanted to be able to put a flower created by me in a flower pot. After realising I have to add a new flower pot with my modded flower and change the onItemUse method I got some issues. Here is my code of the new onItemUse method: public ActionResultType onItemUse(ItemUseContext context) { ItemStack stack = context.getItem(); World world = context.getWorld(); if(stack.getItem()==ItemList.censored_flower) { BlockState state = world.getBlockState(context.getPos()); if(state.getProperties().equals(Blocks.FLOWER_POT.getDefaultState().getProperties())) { world.setBlockState(context.getPos(), BlockList.censored_flower_pot.getDefaultState()); stack.setCount(stack.getCount()-1); return ActionResultType.SUCCESS; } if(state.getBlock()==Blocks.GRASS_BLOCK||state.getBlock()==Blocks.DIRT) { BlockPos pos = new BlockPos(context.getHitVec()); if(world.getBlockState(pos).getBlock()==Blocks.AIR) { world.setBlockState(pos, BlockList.censored_flower.getDefaultState()); stack.setCount(stack.getCount()-1); return ActionResultType.SUCCESS; } } } logger.info("Fail."); return ActionResultType.FAIL; }   So my problem is that the method doesn't seem to register when I rightclick on an empty flower pot while holding my flower. I also tried it with state.getBlock()==Blocks.FLOWER_POT but that didn't work either. The placement on grass and dirt blocks works perfectly. I believe the solution will be easy but I can't find it.   Thank you very much in advance.
  • Topics

  • Who's Online (See full list)