• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Does this mean I can get away with a 1.12 mod and1.12.2 mod  on forge 1.12.2 and they work or no?
    • I'm trying to create a tool which could safely convert any tile entities into a "tile box" and that part works just fine. I stored the block, tile entity data and the block states in that tile box nbt.   Now the problem I'm currently having is trying to render the tile box based of the block if there was a block in the NBT.   For example, I have a chest with some items in it and I use my tool and shift + right-clicked the chest with it and it drop my tile box with the nbt tag. Also, I know I needed two different render classes for both the item's entity (when thrown into the world) and when it is in my inventory.   I have tried creating my own render class and stuck on how I would register the class for my specific `ModItems.TILE_BOX`.   Any ideas on how would I implement these?
    • I created a forge server for me and my friends on forge version 1.12.2-14.23.5.2847 but the mod server doesn't work and thinks they're not there. here is the game log: https://pastebin.com/VeMPaJky
    • Hello guys So i am working on a bigger plugin/mod currently that i want to be compatible with multiple API's like Bukkit, Sponge and now Forge. This is currently built with gradle and the johnrengelman.shadow plugin to make an universal jar. Here is the project. With the last commit in that branch i tried to add the Forge Implementation but when i am trying to build it i get this issue that i don't know how to fix: > Configure project :BlueMapForge New Dep: net.minecraftforge:forge:1.14.4-28.1.0_mapped_stable_58 FAILURE: Build failed with an exception. * What went wrong: Could not determine the dependencies of task ':shadowJar'. > Could not resolve all dependencies for configuration ':runtimeClasspath'. > Could not find net.minecraftforge:forge:1.14.4-28.1.0_mapped_stable_58. ... Here is the full error and gradle scan: https://gradle.com/s/7z2is226v6v3q I am currently using gradle 5.6.4 with this built but i have also tried gradle 4.9 which gets me exactly the same error ^^
    • Hello there again,   So I'm working on a block that has an inventory. It all works fine and such. Now I'd like to render the item in the inventory (max stack size is 1 so technically always a stack with size 1 but I'll call it item) onto the block, when not Air. This is what I have after a morning of trying stuff; https://gist.github.com/Tebreca/28ae1e005f66270427e664f17e10c8b9   The matrix crashes the entire game; https://hastebin.com/simijavara   Whatever I try I cannot find a way to scale down the item; it currently is the size of a real block;   So, how would I go about rendering an ItemStack on top of my block?   Thanks in advance!
  • Topics

  • Who's Online (See full list)