That mods are on 1.7.x because the modders are lazy or simply give up with modding.

And supporting a version released June 26, 2014 (4 years, 2 months according to timeanddate.com, 4 major versions behind) is just wasting precious disk and processing power of the forum, let alone time of Forge devs and moderators.