Welcome, Guest. Please login or register.

Author Topic: Minecraft 1.6 and the new launcher.  (Read 183006 times)

0 Members and 2 Guests are viewing this topic.

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Minecraft 1.6 and the new launcher.
« on: July 03, 2013, 12:28:30 AM »
So, as everyone knows. 1.6 is Out.
We DO have 1.6 builds ready for user/modder consumption.
Mostly modder consumption.

1.6 is MAJOR changes to how the install process goes.
However cpw is awesome and sexy, and made a new Installer for FML/Forge.
You can access the downloads from the Usual Place

The installer is straight forward. Simple one click install for most end users.
If someone would be so kind as to write up fully detailed install instructions both using the installer and manually that'd be awesome!

Aside from that there are a few bugs that will ineveitably pop up. So we'll squash them when we can.
We have a few things that are in pending that we need to finish up. Namely the Liquids re-write. And merging in some MCPC related work from BloodMC.

So, even though you CAN get Forge right now. I wanted to make this announcement so people knew whats up.
We do have Forge working on 1.6.1, and you can download it. But due to some changes and wanting to do a little bug testing we have no plans to make a recommended build untill next Monday or so.

The reason for this change is two fold,
1) We were not able to start work as early as we'd like due to real life concerns of some people.
2) The launcher/MC were in a state of flux for quit a bit and even now hasnt fully stabelized.

Both reasons caused us to not be able to do out own internal builds and testing as soon as we wanted so We did the fastest we could :P

Modder Feel free to start updating your mods. Keep an eye on the changelog/github for more details. And please start writing new 1.6 tutorials!

User You can download and use Forge, buti'd wait untill the mods you want are update first.

As for people complaining that our File server is down. Its not. It is just under a lot of stress. We're looking at 100,000s of people trying to grab Forge all at once. So be patient. There are some mirriors avalible, but none officially sanctioned.

If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline wolfo9999

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #1 on: July 03, 2013, 02:45:43 AM »
Xisumavoid has made a great tutorial on the new launcher.

It explains:
How the launcher works. (youtube)
How to install mods for a .jar (youtube)

It isn't specific for minecraftforge, but the principle is the same as it's just another mod. Should suffice until someone makes a dedicated tutorial.

** I take no credit for this tutorial **

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #2 on: July 03, 2013, 03:24:05 AM »
Actually those tutorials are not to be used, they are the old way of doing things where you still have to edit the jar files {in addition to the jsons}
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline wazza3243

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #3 on: July 03, 2013, 06:23:25 AM »
I'm Having a problem that says this whenever i try and start Minecraft
Gave up trying to download http://files.minecraftforge.net/maven/org/scala-lang/scala-compiler/2.10.2/scala-compiler-2.10.2.jar for job 'Version & Libraries'
Job 'Version & Libraries' finished with 2 failure(s)!
Is there a way to fix this or do I just need to wait until the load is taken of the server because whenever i go to that address i get 404 not found

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #4 on: July 03, 2013, 08:21:05 AM »
Upodate.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline Nish

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #5 on: July 03, 2013, 02:36:29 PM »
Hey :)
First of i would just like to say thank you for all of your hard work on forge. It has made my minecraft experience quite enjoyable.
I would just like to say that i have found a bug. when you put on armour you cant see it on you eve in your inventory or when you go f5 mode. This also occurs with weapons when your in first person you can see yourself holding it but in third person you cant.

Secondly with the manual installation i know that we have to put the forge in the .jar and that the .json is missing some text for it to work with forge. The only way that i find this text is using the installer installing the forge version and copying the text from the auto installer .json to my manual install. is their anyway you could paste the code to make this easier. just to let you know it does work when i copy over the forge json. Thank you
Nish

Offline Mazetar

  • Forge Modder
  • World Shaper
  • ***
  • Thank You
  • -Given: 111
  • -Receive: 203
  • Posts: 1251
  • Karma: +280/-14
  • On a fun quest to learn programming!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #6 on: July 03, 2013, 03:27:00 PM »
if it's the installer files, can't you just open them yourself?
and for the forge it's all on github.
If you guys dont get it.. then well ya.. try harder...

Offline Ariath

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 9
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #7 on: July 03, 2013, 08:49:14 PM »
I have tested Forge with the client, and i have to say, i'm glad we don't need to do jar editing anymore :D .

But i have a question related to [version].json: ┬┐What rule do we need to follow naming libraries?.

Following the example of Forge and other libraries, i tried creating this directory tree: libraries/internalmods/toomanyitems/1.6.1/TooManyItems.jar.
This is what i added to the forge json, in the libraries section, of course:

Quote
{
    "name": "internalmods.toomanyitems:1.6.1"
}

But the launcher's dev console shows plenty of errors upon starting.

Quote
Couldn't go online
java.lang.ArrayIndexOutOfBoundsException: 2
   at net.minecraft.launcher.versions.Library.getArtifactBaseDir(Library.java:68)
   at net.minecraft.launcher.versions.Library.getArtifactPath(Library.java:73)
   at net.minecraft.launcher.versions.CompleteVersion.getRequiredFiles(CompleteVersion.java:153)
   at ...

I think it can't find the library i added to the json.

See ya!

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #8 on: July 03, 2013, 08:59:11 PM »
It's maven style artifact values, so:
DOMAIN:NAME:VERSION
gets expanded to /libraries/DOMAIN/NAME/VERSION/NAME-VERSION.jar

Aside from that, cpw is working his but off on stream lining the Mod install process to both take advantage of the new structure and be simple for users.

As for the json. I'll see what I can do about including a sample version.json in the universal's jar.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline FyberOptic

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #9 on: July 03, 2013, 09:14:50 PM »
Might I suggest that the Forge installer classify the Forge launcher entry as a "snapshot" instead of a "release?"  Otherwise, the Default profile will always think that the Forge entry is the newest Minecraft version, leaving you unable to run vanilla unless you specifically select the version.

Offline enricogp

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #10 on: July 03, 2013, 09:42:34 PM »
"Gave up trying to download xxxx", how do I fix it? (I don t know if I doubleposted, as my other reply "disappeared")

Offline muizzsiddique

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #11 on: July 03, 2013, 09:44:54 PM »
Might I suggest that the Forge installer classify the Forge launcher entry as a "snapshot" instead of a "release?"  Otherwise, the Default profile will always think that the Forge entry is the newest Minecraft version, leaving you unable to run vanilla unless you specifically select the version.
Actually FyberOptic, there is a easier way to fix it. Just go into the .json file and change the release date to a earlier date than the actual game in "releaseTime" and it should be fixed.  :) Hope this helped
« Last Edit: July 03, 2013, 09:48:39 PM by muizzsiddique »

Offline muizzsiddique

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #12 on: July 03, 2013, 09:47:12 PM »
"Gave up trying to download xxxx", how do I fix it? (I don t know if I doubleposted, as my other reply "disappeared")
Hey enricogp, there is currently no way to fix it (that I know of) however that is very normal. It says that to let you know Mojang haven't released a version with that name so it can't update it, which is exactly what you want.
« Last Edit: July 03, 2013, 09:49:05 PM by muizzsiddique »

Offline FyberOptic

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #13 on: July 03, 2013, 09:59:24 PM »
Actually FyberOptic, there is a easier way to fix it. Just go into the .json file and change the release date to a earlier date than the actual game in "releaseTime" and it should be fixed.  :) Hope this helped

I thought of that, and it is certainly a good solution as well.  But in terms of ease of programming for their installer, it would be simpler to just change "release" to "snapshot" than to determine the newest version in the launcher, read its JSON file, find the release date, parse it back into a value, then decrement it.  (EDIT: Nevermind, I guess they could just obtain the release time and hard-code their own value lesser than that.)  It would also allow them to keep the actual dates of the Forge releases in the JSON, which will naturally always be after the vanilla release.

It's a shame that the launcher barfs when you try to use something other than "snapshot" or "release" to classify an entry.
« Last Edit: July 03, 2013, 10:05:58 PM by FyberOptic »

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #14 on: July 03, 2013, 10:14:26 PM »
In that aspect everyone should go yell at Mojang to add 'Use latest _____'
So you can select 'Use Latest Release' 'Use Latest Snapshot' 'Use Latest Forge' etc..
But untill that time we're just gunna make the time 1960 because meh
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline jeffw

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
  • Karma: +1/-0
  • Gender: Male
  • You are new! MyWikis.com is not.
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #15 on: July 04, 2013, 02:30:44 AM »
Hi guys,
I've taken the liberty of making the tutorial. I've split up the content into sections. Let me know if you need anything else.
« Last Edit: July 04, 2013, 04:57:11 AM by LexManos »
Jeff

COO and CTO of MyWikis.com
Server owner at NewSumeria.com

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #16 on: July 04, 2013, 04:56:18 AM »
If you've made a tutorial.. you should link it.
Instead of advertising yourself/your server -.-
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

Offline InfamousTrooper

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #17 on: July 04, 2013, 06:04:19 AM »
I can't run this jar but I can run other jars. So I tried to run it with a batch file and this popped up! How do I Fix this?

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 558
  • Posts: 4444
  • Karma: +947/-216
  • I am new!
    • View Profile
Re: Minecraft 1.6 and the new launcher.
« Reply #18 on: July 04, 2013, 06:19:06 AM »
This is NOT the support forum -.-
And it means you dont have the libraries.
The error is pretty damn straight forward...
I'm gunna lock this because it seems to not being productive.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn (Because, people asked 0.o)

 

Close
Please register or Login to join in on the community!