Welcome, Guest. Please login or register.

Author Topic: Forge Decompile Error  (Read 5312 times)

0 Members and 1 Guest are viewing this topic.

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Forge Decompile Error
« on: January 12, 2013, 03:59:07 PM »
Hello, everyone.

I have minecraft 1.4.6. I'm trying to install forge by using minecraftforge-src-1.4.6-6.5.0.489.

Here's my error, when I double-click install.cmd (using windows 7 x64), I get the following output:

Hidden
================ Forge ModLoader Setup Start ===================
MCP Detected already, not downloading
Setting up MCP
Restoring commands.py backup
patching file commands.py
Commands patch applied successfully
Copying FML conf
Creating re-packaged srg
Creating re-packaged exc
Creating re-packaged MCP patch
== MCP 7.25 (data: 7.25, client: 1.4.6, server: 1.4.6) ==
WARNING:
The cleanup script will delete all folders created by MCP, including the
src folder which may contain changes you made to the code, along with any
saved worlds from the client or server.
If you really want to clean up, enter "Yes" Yes
> Cleaning temp
> Cleaning src
> Cleaning bin
> Cleaning reobf
> Cleaning lib
> Cleaning jars
> Cleaning logs
File Exists: lwjgl.jar
File Exists: lwjgl_util.jar
File Exists: jinput.jar
File Exists: windows_natives.jar
File Exists: macosx_natives.jar
File Exists: linux_natives.jar
File Exists: minecraft.jar
File Exists: minecraft_server.jar
== MCP 7.25 (data: 7.25, client: 1.4.6, server: 1.4.6) ==
# found ff, ff patches, srgs, name csvs, doc csvs, param csvs, renumber csv, ast
yle, astyle config
> Creating Retroguard config files
== Decompiling client using fernflower ==
> Creating SRGs
> Applying Retroguard
> Compiling AccessTransformer
FATAL ERROR
Traceback (most recent call last):
  File "C:\Users\Joel\Downloads\minecraftforge-src-1.4.6-6.5.0.489\forge\mcp\runtime\decompile.py", line 116, in decompile
    strip_comments=strip_comments, exc_update=exc_update)
  File "C:\Users\Joel\Downloads\minecraftforge-src-1.4.6-6.5.0.489\forge\mcp\run
time\mcp.py", line 30, in decompile_side
    commands.applyrg(side)
  File "C:\Users\Joel\Downloads\minecraftforge-src-1.4.6-6.5.0.489\forge\fml\fml
.py", line 263, in applyrg_shunt
    if not runcmd(self, cmd_compile.format(target=os.path.join(dir_trans, 'Acces
sTransformer.java')), echo=False):
  File "C:\Users\Joel\Downloads\minecraftforge-src-1.4.6-6.5.0.489\forge\fml\fml
.py", line 359, in runcmd
    process = subprocess.Popen(forklist, stdout=subprocess.PIPE, stderr=subproce
ss.STDOUT, bufsize=-1)
  File "subprocess.pyc", line 679, in __init__
  File "subprocess.pyc", line 896, in _execute_child
WindowsError: [Error 193] %1 is not a valid Win32 application
Decompile Exception: 1
Press any key to continue . . .

I downloaded a clean 1.4.6 minecraft.jar file from here:

I also noticed that on previous attempts at running install.cmd, that it also downloaded clean minecraft.jar and minecraft_server.jar files.

Please help!

-traugdor
I make mod packs for my friends. They don't usually play with them.

Offline Chibill

  • Forge Modder
  • Diamond Finder
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 21
  • Posts: 491
  • Karma: +25/-17
  • Gender: Male
  • Owner of AdditionalCrafting Mod!
    • View Profile
    • My mods files
Re: Forge Decompile Error
« Reply #1 on: January 12, 2013, 07:50:02 PM »
If you are developing mods get the forge latest version for 1.4.7 and run the install it should work.

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #2 on: January 12, 2013, 08:19:27 PM »
If you are developing mods get the forge latest version for 1.4.7 and run the install it should work.

I'm actually trying to correct a mod imcompatibility for my personal mod pack. The mod pack requires 1.4.6 because not all of the mods have been updated to 1.4.7 yet.
I make mod packs for my friends. They don't usually play with them.

Online LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 640
  • Posts: 5233
  • Karma: +1080/-240
  • I am new!
    • View Profile
Re: Forge Decompile Error
« Reply #3 on: January 12, 2013, 09:01:36 PM »
Seems you dont have a JDK installed or MCP cant find it, this you know.. is kinda needed to compile java -.-
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #4 on: January 12, 2013, 09:26:08 PM »
Seems you dont have a JDK installed or MCP cant find it, this you know.. is kinda needed to compile java -.-

I installed JDK 1.6.0_38, I think. It says it installed and the folders are there in "c:\program files\java\".
I make mod packs for my friends. They don't usually play with them.

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #5 on: January 12, 2013, 11:03:08 PM »
I made doubly sure I installed JDK and set the path variables properly. I tried numerous src builds of forge, but none of them seem to work. They all halt at the same place, with the same error. The only thing I haven't tried is using JDK7 because I have friends who like to play with me and they will want the same fix that I am making.

If MCP can't find JDK, then I don't know what I'm doing wrong.

EDIT:

I just tried with JDK7. Didn't work. Same error. Same place. I can't be the only one with this error.
« Last Edit: January 12, 2013, 11:08:07 PM by traugdor »
I make mod packs for my friends. They don't usually play with them.

Offline Chibill

  • Forge Modder
  • Diamond Finder
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 21
  • Posts: 491
  • Karma: +25/-17
  • Gender: Male
  • Owner of AdditionalCrafting Mod!
    • View Profile
    • My mods files
Re: Forge Decompile Error
« Reply #6 on: January 13, 2013, 02:20:06 AM »
What about the JRE.

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #7 on: January 13, 2013, 04:41:39 AM »
What about the JRE.

Um the JRE comes WITH the JDK................ it installed separately in its own folder beside the JDK.
I make mod packs for my friends. They don't usually play with them.

Online LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 640
  • Posts: 5233
  • Karma: +1080/-240
  • I am new!
    • View Profile
Re: Forge Decompile Error
« Reply #8 on: January 13, 2013, 05:13:38 AM »
Make sure that it is in your class path properly.
Also, post a mcp.log {pastebin}
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #9 on: January 13, 2013, 03:55:21 PM »
Make sure that it is in your class path properly.
Also, post a mcp.log {pastebin}

Not sure what you mean about "class path", but I doublechecked the PATH variable and the correct path to JRE\bin is in there.

mcp.log: http://pastebin.com/zKpB98gM
I make mod packs for my friends. They don't usually play with them.

Offline Cloudy

  • Stone Miner
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 67
  • Karma: +8/-0
  • I am new!
    • View Profile
Re: Forge Decompile Error
« Reply #10 on: January 14, 2013, 02:09:10 PM »
I have actually seen this issue before recently. The problem is the quotation marks around %s in fml.py - on some systems it doubles them. No idea why, but removing the quotation marks should work.

Offline traugdor

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
  • Karma: +0/-0
  • Gender: Male
  • Yes, I read the stickies before posting.
    • View Profile
Re: Forge Decompile Error
« Reply #11 on: January 16, 2013, 08:40:37 PM »
I have actually seen this issue before recently. The problem is the quotation marks around %s in fml.py - on some systems it doubles them. No idea why, but removing the quotation marks should work.

I will try this and get back to ya.
I make mod packs for my friends. They don't usually play with them.

Offline Bektor

  • Forge Modder
  • Creeper Killer
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 2
  • Posts: 189
  • Karma: +2/-0
  • Gender: Male
  • Founder and Coder of the Primeval Forest Mod.
    • View Profile
Re: Forge Decompile Error
« Reply #12 on: April 03, 2013, 11:46:09 AM »
I have the same error in Minecraft 1.5.1, but when I'm removed the quotation marks around %s in fml.py, then crashed the installer too. But then this is a different crash report.  :(
Developer of Primeval Forest.

 

Close
Please register or Login to join in on the community!