Welcome, Guest. Please login or register.

Author Topic: "Forge is setting up Minecraft environment" stuck at 0%, causes exceptions  (Read 18968 times)

0 Members and 1 Guest are viewing this topic.

Related Topics

  Subject / Started by Replies Last post
3 Replies
22671 Views
Last post December 17, 2012, 10:47:26 AM
by keepcalm
3 Replies
4115 Views
Last post May 18, 2013, 10:43:21 PM
by mrDLSable
1 Replies
1666 Views
Last post April 13, 2013, 07:19:53 PM
by loordgek
2 Replies
5886 Views
Last post July 16, 2013, 08:56:27 PM
by loordgek
1 Replies
3652 Views
Last post September 02, 2013, 09:15:43 AM
by luacs1998

Offline leoham

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
So I installed Forge 4.1.1 on Minecraft 1.3.2 without any other mods because I wanted to see if it would work first, but when I run Minecraft the Forge window that says "Forge is setting up your Minecraft environment" comes up and the loading bar just stays at 0%.

I'm running Ubuntu 12.04 and using OpenJDK Java 7 Runtime.

Here's what the console says:
Hidden
Exception in thread "Thread-5" java.lang.NoClassDefFoundError: cpw/mods/fml/client/FMLTextureFX
   at java.lang.ClassLoader.defineClass1(Native Method)
   at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
   at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
   at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
   at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
   at java.lang.Class.getDeclaredMethods0(Native Method)
   at java.lang.Class.privateGetDeclaredMethods(Class.java:2444)
   at java.lang.Class.getDeclaredMethod(Class.java:1952)
   at cpw.mods.fml.relauncher.ReflectionHelper.findMethod(ReflectionHelper.java:170)
   at cpw.mods.fml.relauncher.FMLRelauncher.computeExistingClientHome(FMLRelauncher.java:183)
   at cpw.mods.fml.relauncher.FMLRelauncher.relaunchApplet(FMLRelauncher.java:229)
   at cpw.mods.fml.relauncher.FMLRelauncher.appletEntry(FMLRelauncher.java:200)
   at net.minecraft.client.MinecraftApplet.init(MinecraftApplet.java:28)
   at net.minecraft.Launcher.replace(Launcher.java:143)
   at net.minecraft.Launcher$1.run(Launcher.java:87)
Caused by: java.lang.ClassNotFoundException: cpw.mods.fml.client.FMLTextureFX
   at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
   ... 20 more

I deleted META-INF and everything, am I missing a class or something? Thanks in advance.

EDIT: I would post ModLoader.txt and the ForgeModLoader logs but it didn't create any.
« Last Edit: September 13, 2012, 12:13:13 AM by leoham »

Offline ObsequiousNewt

  • Forge Modder
  • Dragon Slayer
  • ***
  • Thank You
  • -Given: 11
  • -Receive: 64
  • Posts: 720
  • Karma: +86/-4
  • Open-Source is swell!
    • View Profile
    • No Place like Home
Re: "Forge is setting up Minecraft environment" stuck at 0%, causes exceptions
« Reply #1 on: September 13, 2012, 12:19:09 AM »
Looks like you may have got an incomplete download or install... Try redownloading and installing.
BEWARE OF GOD
---
Co-author of Pentachoron Labs' SBFP Tech.

Offline leoham

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: "Forge is setting up Minecraft environment" stuck at 0%, causes exceptions
« Reply #2 on: September 13, 2012, 12:32:30 AM »
Looks like you may have got an incomplete download or install... Try redownloading and installing.

I tried that and it didn't work, and I had the same problem with 4.0.0

Also when I run Minecraft from Eclipse with mcp and forge it runs fine, so I'm not sure what might be wrong
« Last Edit: September 13, 2012, 12:35:24 AM by leoham »

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 652
  • Posts: 5324
  • Karma: +1099/-243
  • I am new!
    • View Profile
Re: "Forge is setting up Minecraft environment" stuck at 0%, causes exceptions
« Reply #3 on: September 13, 2012, 12:37:46 AM »
There is only one cause of the issue you've posted
Ad thats not a proper install
I dont know what to say but install forge properly.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline leoham

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: "Forge is setting up Minecraft environment" stuck at 0%, causes exceptions
« Reply #4 on: September 13, 2012, 12:41:48 AM »
There is only one cause of the issue you've posted
Ad thats not a proper install
I dont know what to say but install forge properly.

Ok yeah I've looked around in my minecraft.jar and it is indeed missing a bunch of the classes that should be there, I guess it was just something I or the archive manager did when I copied them, I'm going to try and put in all the missing ones.

thank you most kindly

 

Close
Please register or Login to join in on the community!