Welcome, Guest. Please login or register.

Author Topic: Local Server: Disconnect.overflow/End of stream  (Read 6486 times)

0 Members and 1 Guest are viewing this topic.

Offline Kragoth

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: +0/-0
  • I am new!
    • View Profile
Local Server: Disconnect.overflow/End of stream
« on: September 07, 2012, 10:21:50 PM »
Sorry if i post in this section, but i haven't find yet the right place :(

I have created a local minecraft server v1.3.2 with MinecraftForge version 4.0.0.249 and 4 mods:
-Universal Electricity_v0.7.0.97
-ICBM_v0.5.3
-Blastcraft_v0.1.3.89
-OptiFine_1.3.2_HD_U_B3

My computer specifics:
Ram:16Gb;
CPU:Intel Core i7-3930k 3.2GHz;
Video card: Nvidia GeForce GTX 570 1.2Gb
Operating system: Windows 7 64Bit
Minecraft server and client use java7 and each one have 6Gb Ram dedicated.

I created a new world with all the mods, when i start to place mod's blocks, the server begin to work abnormally and the client start lagging, if i place other mod's blocks the client start lagging heavily then he kick me with this error message:"Connection Lost, End of Stream"
Then i begin to delete the mods(first Blastcraft, second ICBM then Universal Electricity) to find what is unstable.
if i delete all the mods, the server/client stop lagging(obviously)but if i use one of those the client crash...
I tried to give more ram to the server(from 6 to 12Gb) but nothing.

Also in the command prompt of the server appear this message when the client is disconnected:
2012-09-07 13:27:31  [ForgeModLoader] User ******** connecting with mods [UniversalElectricity, BasicComponents, ICBM, BlastCraft]
2012-09-07 13:27:38  [STDERR]     at java.net.SocketOutputStream.socketWrite(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at java.net.SocketOutputStream.write(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at ako.write(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at java.io.BufferedOutputStream.flush(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at java.io.DataOutputStream.flush(Unknown Source)
2012-09-07 13:27:38  [STDERR]     at bd.run(SourceFile:120)

Someone can help me?  :'( :'( :'(

Offline DarkGuardsman

  • Forge Modder
  • Dragon Slayer
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 32
  • Posts: 888
  • Karma: +62/-2
  • Gender: Male
  • Too Many Mods
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #1 on: September 07, 2012, 10:29:37 PM »
the server i run "DarkEnergy" has this same issue and i have yet to track down what is causing it. But to hear its not the only server is a good thing. Since i can't take down the mods off my server without killing the world can you try creating a server with non UE mods and see if you get the same effect. Then try with just UE.

Offline Kragoth

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #2 on: September 08, 2012, 09:34:05 AM »
I created a world with only EU and i placed random mod's blocks(battery box, coal generator, copper wire), i have noticed that if i place a certain number of copper wire the server start work abnormally and the client have a little lag; if i continue placing copper wire the client is disconnected with the same error(End of stream), with about 250 copper wire the world is gone and the client is disconnected after 10 seconds or less.
I have no idea which mod i can use to test the server(it's really difficult to find other mods similar to EU), i'll try to find something.

Nothing, i have tried with other mods but only EU create this problem...
« Last Edit: September 08, 2012, 03:24:14 PM by Kragoth »

Offline DarkGuardsman

  • Forge Modder
  • Dragon Slayer
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 32
  • Posts: 888
  • Karma: +62/-2
  • Gender: Male
  • Too Many Mods
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #3 on: September 08, 2012, 04:06:53 PM »
I created a world with only EU and i placed random mod's blocks(battery box, coal generator, copper wire), i have noticed that if i place a certain number of copper wire the server start work abnormally and the client have a little lag; if i continue placing copper wire the client is disconnected with the same error(End of stream), with about 250 copper wire the world is gone and the client is disconnected after 10 seconds or less.
I have no idea which mod i can use to test the server(it's really difficult to find other mods similar to EU), i'll try to find something.

Nothing, i have tried with other mods but only EU create this problem...
ok thats what i though i'll talk to Calc about it. He did something to his tick manager(controls the updates for the block) so that it ran per world. He might have messed up a bit but also i don't think he has tested server side much. Also are you getting it where some players have no issues at all? but others crash.

Offline calclavia

  • Moderator
  • World Shaper
  • *****
  • Thank You
  • -Given: 20
  • -Receive: 36
  • Posts: 1419
  • Karma: +90/-8
  • Gender: Male
  • ICBM Mod: http://calclavia.com/icbm/
    • View Profile
    • Calclavia
Re: Local Server: Disconnect.overflow/End of stream
« Reply #4 on: September 09, 2012, 03:26:47 AM »
No idea. Not replicatable in my server. Never got this error.

Offline DarkGuardsman

  • Forge Modder
  • Dragon Slayer
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 32
  • Posts: 888
  • Karma: +62/-2
  • Gender: Male
  • Too Many Mods
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #5 on: September 09, 2012, 05:04:56 AM »
No idea. Not replicatable in my server. Never got this error.
Do you connect locally to your server or remotely because i only seem to get it remotely and rarely. Others get it constantly enough that my server barely runs. Right now i'm trying to work around a 503 http error for my server :( if i don't get thing running soon the server might shutdown for good.

Also the end of stream error is related to enough lag that minecraft considers the player disconnected. Build craft and IC2 use to get something similar Disconnect.overflow for a long time. For buildcraft it related to pipes building up so many items that on pipes break it hit the client with 10K+ packets. For IC2 if i recall right it was too many machines tried to get energy from the same output. For UE it might be similar that the client is getting too many update a tick to function. Try looking over your tick manager for anything that could be causing issues.

Offline calclavia

  • Moderator
  • World Shaper
  • *****
  • Thank You
  • -Given: 20
  • -Receive: 36
  • Posts: 1419
  • Karma: +90/-8
  • Gender: Male
  • ICBM Mod: http://calclavia.com/icbm/
    • View Profile
    • Calclavia
Re: Local Server: Disconnect.overflow/End of stream
« Reply #6 on: September 09, 2012, 10:52:26 AM »
No idea. Not replicatable in my server. Never got this error.
Do you connect locally to your server or remotely because i only seem to get it remotely and rarely. Others get it constantly enough that my server barely runs. Right now i'm trying to work around a 503 http error for my server :( if i don't get thing running soon the server might shutdown for good.

Also the end of stream error is related to enough lag that minecraft considers the player disconnected. Build craft and IC2 use to get something similar Disconnect.overflow for a long time. For buildcraft it related to pipes building up so many items that on pipes break it hit the client with 10K+ packets. For IC2 if i recall right it was too many machines tried to get energy from the same output. For UE it might be similar that the client is getting too many update a tick to function. Try looking over your tick manager for anything that could be causing issues.

I have three players on my server hosted locally. So far I and they have got no error like that...

Offline Kragoth

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #7 on: September 09, 2012, 02:59:35 PM »
I have a question for you, calcavia: can you tell me which version of java are you using to run the server( java 32 or 64bit and the build; i am using java 64 bit, build 1.7.0_07-b11) and the version of the mod you are using(the last version of UE, ICBM and Blastcraft?)?
if in your pc the server don't create problem, i'm doing something wrong...i have tried to delate EVERYTHING related to Minecraftand re-download and install client and server with only forge(v. 4.1.1.251) and EU...but i have the same problem...

I use this string to start client/server with 4Gb of ram: "C:\Program Files\Java\jre7\bin\java.exe" -Xmx4075M -Xms4075M -jar Minecraft.jar(for client) -jar minecraft_server.jar(for server)
is it right?

Offline aidancbrady

  • Forge Modder
  • Tree Puncher
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 20
  • Karma: +1/-0
  • I am new!
    • View Profile
Re: Local Server: Disconnect.overflow/End of stream
« Reply #8 on: September 23, 2012, 06:46:36 PM »
Can confirm I am experiencing the EXACT SAME PROBLEMS.

 

Close
Please register or Login to join in on the community!