Welcome, Guest. Please login or register.

Author Topic: Forge Install Error for Minecraft 1.6.4 Launcher  (Read 39563 times)

0 Members and 1 Guest are viewing this topic.

Related Topics

  Subject / Started by Replies Last post
7 Replies
11524 Views
Last post August 27, 2012, 09:24:34 PM
by Myroshiman
1 Replies
8237 Views
Last post July 03, 2013, 09:13:49 PM
by OpposingForces
2 Replies
5112 Views
Last post July 10, 2013, 05:03:58 PM
by Mopargamer
1 Replies
14729 Views
Last post July 21, 2013, 06:20:23 PM
by LexManos
12 Replies
4479 Views
Last post December 24, 2013, 11:21:44 PM
by LexManos

Offline WolfofWar4126

  • Tree Puncher
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Forge Install Error for Minecraft 1.6.4 Launcher
« on: September 21, 2013, 11:58:43 PM »
I am having an issue with installing any of the forge versions into my mine craft 1.6.4 . Here is what is happening. I am on a Mac OS X version 10.8.4 . When I run the Minecraft forge installer version 9.10.1.871, I have also tried various other version, I run into an issue when it starts to download the files into my //Users/****/Library/Application Support/minecraft folder. After I press the ok button to start the process runs until it gets to downloading the library files. Then an error message appears stating this. "These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-comiler:2:10.2" After attempting to re-download forge with various versions they all come to the same error. What is preventing this download from happening, and what can I do on my computer to fix this?

Offline luacs1998

  • Administrator
  • World Shaper
  • *****
  • Thank You
  • -Given: 5
  • -Receive: 184
  • Posts: 2029
  • Karma: +254/-12
  • Red crayons!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #1 on: September 22, 2013, 02:30:57 AM »
Download this: http://personal.forgeessentials.com/luacs1998/libraries.zip and extract it to your .minecraft folder.
Read the EAQ before posting! OR ELSE!

luacs isn't part of the Forge team, he can do whatever the hell he wants.

Quote from: cpw
This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

www.forgeessentials.com

Follow members gave a thank to your post:


Offline Elasmophile

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #2 on: September 22, 2013, 02:38:10 PM »
I am having the exact same problem. I am running Minecraft 1.6.4, and trying to install Forge using the latest build (9.11.0.883). I've tried installing on a clean install of 1.6.4, get the error message "These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-comiler:2:10.2." I have downloaded the libraries.zip file that lucas1998 provided the link for, and extracted the file to my .minecraft folder, but still I am getting the same error message.

BTW, I am running Mac OSX 10.6.8, if that makes any difference.

Offline WolfofWar4126

  • Tree Puncher
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #3 on: September 22, 2013, 06:59:02 PM »
Lucas your library file helped me out a lot thx. Elasmophile did you replace the library folder with the one you got from or did you put the zip into the .minecraft folder? Because you should have replaced the previous library folder.

Offline Protopopulus

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #4 on: September 22, 2013, 07:16:47 PM »
This error is actual for me too. I tried to re-download recommended installer, it's strange, but it isn't work again =) I have a clean MC 1.6.4, latest Java 7 Oracle on Linux Ubuntu.

It's not fine if we must to download some libraries from other resources, IMHO.

Offline WolfofWar4126

  • Tree Puncher
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #5 on: September 22, 2013, 08:36:36 PM »
Sorry can't help you with linux but did you grab the linux versions of the files that have a linux version?

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 635
  • Posts: 5159
  • Karma: +1067/-239
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #6 on: September 22, 2013, 08:50:49 PM »
You only have to manually install if for some reason your computer can't download them from our servers.
We've done everything on our end we can do to set it up for users to download, its down to users having good internet, and the server not crushing under the load.
And no there are no OS specific version of these libraries so you don't have to worry about that.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline Elasmophile

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #7 on: September 22, 2013, 09:49:07 PM »
My first attempt after downloading the library.zip, I unarchived it, and replaced the Library folder with the unpacked one, and then tried to install Forge. My first attempt was unsuccessful.

I just tried it again, and this time it worked! I didn't do anything differently (I don't think), but it's working now! Thanks everyone!

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 635
  • Posts: 5159
  • Karma: +1067/-239
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #8 on: September 22, 2013, 10:24:43 PM »
Do not REPLACE, you want to MERGE.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline Protopopulus

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #9 on: September 22, 2013, 10:39:37 PM »
Sorry can't help you with linux but did you grab the linux versions of the files that have a linux version?
Emm, sorry... What files you mean? Java applications is multiplatform and can be executed on each OS where installed JRE or isn't?

Ha! I did it!!! =) FML was installed with help of mighty console. I just exectuted installer.jar... ??? However, thanks for reply.

Offline Protopopulus

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #10 on: September 23, 2013, 01:48:32 AM »
Dudes, I have solution for this trouble (for me). Maybe it's helps someone else. FML Installer downloads damaged scala files and JVM cannot open it.

Step 1: Run FML Installer. Check %MC FOLDER%/versions - if installer created "1.6.4-Forge-blah-blah" folder, then move to step 2.

Step 2: Download these files:
http://repo1.maven.org/maven2/org/scala-lang/scala-library/2.10.2/scala-library-2.10.2.jar
http://repo1.maven.org/maven2/org/scala-lang/scala-compiler/2.10.2/scala-compiler-2.10.2.jar

Step 3: Replace files what been downloaded with FML Installer. It placed at %MINECRAFT FOLDER%/libraries/org/scala-lang/....

This solution works with MagicLauncher.

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 635
  • Posts: 5159
  • Karma: +1067/-239
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #11 on: September 23, 2013, 02:12:21 AM »
Quit using the older installer, I'be re-uploaded all the installers and they will now verify the libraries when they download.
As long as you arnt using a older version then you should be fine.
Manual installs work as well, but the installer works fine.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

Offline kristynrenee

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #12 on: September 24, 2013, 03:33:18 AM »
I'm having the same problem. (These libraries failed to download. Try again. org.scala-lang:scala-library:2.10.2, org.scala-lang:scala-compiler:2.10.2) I tried downloading that libraries zip file provided above, and merged with current libraries file; no go.

Offline erb1999

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #13 on: September 26, 2013, 09:23:42 PM »
Quit using the older installer, I'be re-uploaded all the installers and they will now verify the libraries when they download.
As long as you arnt using a older version then you should be fine.
Manual installs work as well, but the installer works fine.
where do we find these installers because when i run the one that i downloaded 30 minutes ago it will get 1/3 of the way done and stop moving and then open an error report that says:
These libraries failed to download.  Try again.
org.scala-lang:2.10.2, org.scala-lang:scala-compiler:2.10.2

Offline imortal000

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #14 on: September 27, 2013, 06:32:11 AM »
Quit using the older installer, I'be re-uploaded all the installers and they will now verify the libraries when they download.
As long as you arnt using a older version then you should be fine.
Manual installs work as well, but the installer works fine.
where do we find these installers because when i run the one that i downloaded 30 minutes ago it will get 1/3 of the way done and stop moving and then open an error report that says:
These libraries failed to download.  Try again.
org.scala-lang:2.10.2, org.scala-lang:scala-compiler:2.10.2

I 2nd this, the latest installer gives same error nothings different. high dollar gaming comp, no virus's win7,64bit and internet is fine. its either broken servers or installer. the only way i manged to get it working is by REPLACING the lib files from the link at the top of this thread, But when forge is selected in the launcher and try to run the game it just crash's every time.
« Last Edit: September 27, 2013, 06:34:48 AM by imortal000 »

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 635
  • Posts: 5159
  • Karma: +1067/-239
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #15 on: September 27, 2013, 07:24:27 PM »
I need your exact specs. Jvm and os.
Also need the console log of you running the installer
Also need the files that the installer downloads located in the libraries/org/scala-lang folder.

If shit is broken for you I need more the "shits broken yo" I need information I can work with. I should be back in town later tonight if those who are having issues want to join the irc. The more cooperation and help I have tracking down the bug the sooner it gets fixed.

Offline imortal000

  • Tree Puncher
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #16 on: September 28, 2013, 12:42:44 PM »
Well, apparently I got forge loading, it appears the mod itself was crashing the game, for some reason one tiny hotfix from minecraft makes mods not work now. Haven't played in a while but I remember you could go a hotfix or two  out of date and it would still work....kina strange. specially since the small (1 or 2) fixs mojang made don't even have anything to do with the mod.

Offline LexManos

  • Forge Code God
  • Reality Controller
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 635
  • Posts: 5159
  • Karma: +1067/-239
  • I am new!
    • View Profile
Re: Forge Install Error for Minecraft 1.6.4 Launcher
« Reply #17 on: September 28, 2013, 05:55:51 PM »
that was only ever the case on changes that didn't change the obfusication, 1.6.2, 1.6.3, and 1.6.4 DID change the obfusication. So mods need to update.
If you don't know how to run a java file you're a moron and should watch this: http://www.youtube.com/watch?v=j6uMF-PjGT4
BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn
Patreon: http://www.patreon.com/lexmanos (Because, people asked 0.o)

 

Close
Please register or Login to join in on the community!